Subversion 1.6 sur Debian lenny

alors là c’est le billet mémo par excellence :)

étant utilisateur occasionnel de tortoiseSVN à jour, impossible pour moi d’utiliser svn en ligne de commande (beaucoup plus rapide que tortoise) sur ma debian, d’où l’idée de d’installer svn 1.6 qui n’est pas disponible dans les paquets debian.

la procédure consiste a utiliser les backports, elle est très simple, encore faut-il la connaitre (ou la trouver facilement)

pour commencer il faut savoir que svn 1.5 doit être déjà installé sur la machine, si ce n’est pas le cas, faire :

apt-get install subversion subversion-tools apache2 libapache2-svn

1. configuration du sources.list
il faut ajouter cette ligne à la fin du fichier /etc/apt/sources.list

deb http://www.backports.org/debian lenny-backports main contrib non-free

2. mettre à jour la base de paquets :

apt-get update

3. on instalel svn en spécifiant la source (backports) :

apt-get -t lenny-backports install subversion subversion-tools libapache2-svn

et maintenant on peut utiliser svn en ligne de commande avec des référentiels « commités » avec des version récentes de subversion (comme tortoise)

Source du tuto : http://swherdman.com/2009/05/subversion-16-on-debian-lenny/

Share